Club Cobra GasN Exhaust  

Go Back   Club Cobra > Cobra Talk Areas > ALL COBRA TALK

Welcome to Club Cobra!  The World's largest non biased Shelby Cobra related site!

  •  » Representation from nearly all Cobra/Daytona/GT40 manufacturers
  •  » Help from all over the world for your questions
  •  » Build logs for you and all members
  •  » Blogs
  •  » Image Gallery
  •  » Many thousands of members and nearly 1 million posts! 

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Nevada Classics
Keith Craft Racing
Main Menu
Module Jump:
Nevada Classics
Nevada Classics
MMG Superformance
MMG Superformance
Advertise at CC
Banner Ad Rates
MMG Superformance
Keith Craft Racing
September 2020
S M T W T F S
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30      
  #1 (permalink)  
Old 08-10-2020, 12:36 PM
CC Member
Visit my Photo Gallery

 
Join Date: Jan 2008
Cobra Make, Engine:
Posts: 305
Not Ranked     
Default tach and speedo problem

Tach- at running speed when tach should be at 2500 it vacillates between 2000 and 3000. if at 3000 goes between 2000 and 4000. then stops for awhile then does it again.
Speedo- will be running steady at 60mph then swings down to 20mph then up to 100 back to 20 then will steady out. does this periodically.
Reply With Quote
Sponsored Links
Sponsored Links
  #2 (permalink)  
Old 08-10-2020, 03:53 PM
CC Member
Visit my Photo Gallery

 
Join Date: Nov 2003
Location: New Britain, CT
Cobra Make, Engine: Size 10 Feet
Posts: 2,763
Not Ranked     
Default

What brand instruments are they? Mechanical? Electrical?
What ignition system are you using?
Is the car stuttering when the gauges are malfunctioning?
What is the ammeter/voltmeter showing?
Reply With Quote
  #3 (permalink)  
Old 08-10-2020, 03:57 PM
CC Member
Visit my Photo Gallery

 
Join Date: Nov 2003
Location: New Britain, CT
Cobra Make, Engine: Size 10 Feet
Posts: 2,763
Not Ranked     
Default

duplicate post...
Not my fault.

Last edited by strictlypersonl; 08-10-2020 at 04:00 PM.. Reason: Duplicate post
Reply With Quote
  #4 (permalink)  
Old 08-10-2020, 06:23 PM
CC Member
Visit my Photo Gallery

 
Join Date: Aug 2007
Location: Carlsbad, Ca
Cobra Make, Engine: SPF 2932 with 438 Lykins Motorsports engine. Previous owner of FFR 5452.
Posts: 2,489
Not Ranked     
Default

If you have an electric speedo and tach, you’ve got a wiring problem. Probably loose connection in the fuse box.
When my tach fluctuated, that solved the problem.
If you’ve got a mechanical speedo, the problems are separate and unrelated.
__________________
Jim
Reply With Quote
  #5 (permalink)  
Old 08-10-2020, 07:21 PM
cycleguy55's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Feb 2014
Location: White City, SK
Cobra Make, Engine: West Coast, 460 CID
Posts: 2,326
Not Ranked     
Default

Quote:
Originally Posted by Steve Gallegos View Post
Tach- at running speed when tach should be at 2500 it vacillates between 2000 and 3000. if at 3000 goes between 2000 and 4000. then stops for awhile then does it again.
Speedo- will be running steady at 60mph then swings down to 20mph then up to 100 back to 20 then will steady out. does this periodically.
Mine used to fluctuate as well, but that went away when I replaced my Ford large frame 1G alternator with a Ford 3G alternator. I don't know whether I had a bad alternator diode, bad grounds, poor wire connections or a flaky voltage regulator, but the problems all disappeared after changing the alternator and re-wiring for the 3G and its internal voltage regulator.
__________________
Brian
Reply With Quote
  #6 (permalink)  
Old 08-10-2020, 07:41 PM
rodneym's Avatar
Full Blown Member
Visit my Photo Gallery
Premier Contributor
 
Join Date: Sep 2008
Cobra Make, Engine: KMP 427 S/C, Twin Paxton FE
Posts: 2,566
Not Ranked     
Default

I had the same problem over 10 years ago in my (then) SPF. Blas told me to clean the contact on the distributor cap. Solved.
__________________
rodneym
Reply With Quote
  #7 (permalink)  
Old 08-11-2020, 05:15 AM
Blas's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Sep 2002
Cobra Make, Engine: SPF#0760
Posts: 3,160
Not Ranked     
Default

(Up-Dated)
For Tach: Erosion of the center contact graphite on the cap caused by wear or improper adjustment of the spring contact on the rotor.

For Speedo: Cable routing and/or cable lubrication. If replacement cable, could be a bit too long. If original cable in same position, untouched, add gauge to list.

Chassis numbers would be nice.

Blas
__________________
Wiring Diagrams: SPF MKII, MKIII, GT40, CSX7000, CSX8000, and Shelby Sebring & Bondurant Tribute Cars.
Owner’s Manuals: SPF MKII, CSX7000, CSX8000, Sebring, Bondurant, & Cinema Tribute Cars.

Large, easy to read and trace schematics with part numbers, wire colors, wire gauge, fuses, and electrical upgrade information. Trouble-shooting and replacement part numbers for those roadside repair adventures.
SPFWiringDiagrams@Comcast.net

Last edited by Blas; 08-11-2020 at 06:31 PM..
Reply With Quote
  #8 (permalink)  
Old 08-11-2020, 04:57 PM
RD31's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Sep 2003
Location: Colgate, WI
Cobra Make, Engine: FFR 4071, SHP 408 Carb dry sump, G-Force T-5, 4 into 4 headers, 3-link 8.8 with 3.55 gears in the rear
Posts: 47
Not Ranked     
Default

If you are running mechanical gauges check to make sure they aren't bent to much. If the bend radius of the cables is too tight they will chatter and fluctuate as you described.
Reply With Quote
  #9 (permalink)  
Old 08-14-2020, 06:04 AM
CC Member
Visit my Photo Gallery

 
Join Date: Feb 2018
Location: Pocatello, ID
Cobra Make, Engine: Shell Valley, 428 SCJ
Posts: 2
Not Ranked     
Default

Check your grounds. I had a similar issue.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
The representations expressed are the representations and opinions of the clubcobra.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners, moderators, Shelby American, any other replica manufacturer, Ford Motor Company. This website has been planned and developed by clubcobra.com and its forum members and should not be construed as being endorsed by Ford Motor Company, or Shelby American or any other manufacturer unless expressly noted by that entity. "Cobra" and the Cobra logo are registered trademarks for Ford Motor Co., Inc. clubcobra.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). Thank you for visiting clubcobra.com. For full policy documentation refer to the following link: CC Policy
Links monetized by VigLink