Club Cobra Warrior Cobra Drive  

Go Back   Club Cobra > Manufacturers, Engine Builders, tools, and parts. > BackDraft Racing ---

Welcome to Club Cobra!  The World's largest non biased Shelby Cobra related site!

  •  » Representation from nearly all Cobra/Daytona/GT40 manufacturers
  •  » Help from all over the world for your questions
  •  » Build logs for you and all members
  •  » Blogs
  •  » Image Gallery
  •  » Many thousands of members and nearly 1 million posts! 

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Nevada Classics
Win With A Cobra
Main Menu
Module Jump:
Nevada Classics
Nevada Classics
Win With A Cobra
Advertise at CC
Banner Ad Rates
Keith Craft Racing
Keith Craft Racing
Win With A Cobra
August 2015
S M T W T F S
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31          
  #1 (permalink)  
Old 08-15-2011, 08:40 AM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Unhappy New ignition installed...Cobra still running when switch turned off!

Last month I started a thread about my BDR continuing to running after the ignition was turned off...

It was suggested I should replace the ignition with a brand new Painless ignition switch...

I purchased the new switch...and installed it...drove the Cobra several miles...started and shut down the engine several times...seemed to solve the problem...

I have not driven my Cobra again till yesterday (it's been too hot this summer to enjoy the Cobra much)...so I took the Cobra for a short spin at night...pulled back in the garage...turned off the key... the engine continued to run...I turned off the battery kill switch...turned off the lights...and eventually the engine stopped...

So...I spent a few minutes starting and than turning off the ignition switch...no problems...everything worked great...engine shut down...I could not duplicated the problem again...

OK now...I'm scratching my head...any thoughts on where I go next to permanently solve the problem...it seems to only happen when it's rather hot outside...and the lights are on...but that could be just a coincidence...

Thanks for the assistance...

Randy
BDR#340
Reply With Quote
Sponsored Links
Sponsored Links
  #2 (permalink)  
Old 08-15-2011, 09:16 AM
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2001
Location: Louisville, KY
Cobra Make, Engine: I'm Cobra-less!
Posts: 8,118
Send a message via AIM to blykins
Not Ranked     
Default

Is your electric fan running when it does this? If so, you need a fan relay....otherwise the fan will backfeed voltage into the ignition.
__________________
www.lykinsmotorsports.com
Reply With Quote
  #3 (permalink)  
Old 08-15-2011, 10:18 AM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Default

Quote:
Originally Posted by blykins View Post
Is your electric fan running when it does this? If so, you need a fan relay....otherwise the fan will backfeed voltage into the ignition.
Thanks for the response!

Yes...during all the years I've owned this Cobra...I've always had the manual over-ride toggle switch for the electric fans engaged all the time...thus the fans run all the time...
Reply With Quote
  #4 (permalink)  
Old 08-15-2011, 10:23 AM
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2001
Location: Louisville, KY
Cobra Make, Engine: I'm Cobra-less!
Posts: 8,118
Send a message via AIM to blykins
Not Ranked     
Default

Turn the fan off and make sure it stops spinning before you kill the ignition...see if that helps.
__________________
www.lykinsmotorsports.com
Reply With Quote
  #5 (permalink)  
Old 08-15-2011, 10:47 AM
undy's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jul 2005
Location: Virginia Beach, Va & Port Charlotte, Fl.,
Posts: 1,926
Not Ranked     
Default

I had the same problem with my Cobra and read where installing a diode in your alternator's wiring to stop voltage feed-back and the subsequent run-on problem. This is a common problem with "home wired" alternator systems. It sure cured my woes. There's even instructions included with MSD's boxes that talks about this.
__________________
Too many toys?? never!

Last edited by undy; 08-15-2011 at 10:51 AM..
Reply With Quote
  #6 (permalink)  
Old 08-15-2011, 11:21 AM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Default

Quote:
Originally Posted by undy View Post
I had the same problem with my Cobra and read where installing a diode in your alternator's wiring to stop voltage feed-back and the subsequent run-on problem. This is a common problem with "home wired" alternator systems. It sure cured my woes. There's even instructions included with MSD's boxes that talks about this.
The perplexing question I have is...I've owned this Cobra for 4 years...and never had this problem until recently...
Reply With Quote
  #7 (permalink)  
Old 08-15-2011, 12:32 PM
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2001
Location: Louisville, KY
Cobra Make, Engine: I'm Cobra-less!
Posts: 8,118
Send a message via AIM to blykins
Not Ranked     
Default

Have you been doing any carb tuning?
__________________
www.lykinsmotorsports.com
Reply With Quote
  #8 (permalink)  
Old 08-15-2011, 02:21 PM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Default

Quote:
Originally Posted by blykins View Post
Have you been doing any carb tuning?
No carb tuning...why do you ask?
Reply With Quote
  #9 (permalink)  
Old 08-15-2011, 02:48 PM
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2001
Location: Louisville, KY
Cobra Make, Engine: I'm Cobra-less!
Posts: 8,118
Send a message via AIM to blykins
Not Ranked     
Default

There are several symptoms of run-on, and there are some things that you can do to the carb to cause it. A high idle can cause run-on, along with a vacuum leak, etc.
__________________
www.lykinsmotorsports.com
Reply With Quote
  #10 (permalink)  
Old 08-15-2011, 03:06 PM
Cashburn's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2004
Location: North Haven, CT
Cobra Make, Engine: Backdraft
Posts: 4,654
Not Ranked     
Default

Don't think we are talking about run-on here are we? You are actually experiencing a condition where you turn the ignition switch off... yet the car keeps running like it is still in the on position? Right? Like it will keep running until you physically kill it somehow?
__________________
IT'S NOT REAL. IT'S UNREAL.
VINTAGE MOTORSPORTS
888.427.1965 | www.vintagemotorsports.com
Reply With Quote
  #11 (permalink)  
Old 08-15-2011, 03:07 PM
CC Member
Visit my Photo Gallery

 
Join Date: Dec 2001
Location: Louisville, KY
Cobra Make, Engine: I'm Cobra-less!
Posts: 8,118
Send a message via AIM to blykins
Not Ranked     
Default

We may not be Jay, but I wanted to cover all the bases.
__________________
www.lykinsmotorsports.com
Reply With Quote
  #12 (permalink)  
Old 08-15-2011, 06:48 PM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Default

Quote:
Originally Posted by Cashburn View Post
Don't think we are talking about run-on here are we? You are actually experiencing a condition where you turn the ignition switch off... yet the car keeps running like it is still in the on position? Right? Like it will keep running until you physically kill it somehow?
Hi Jay...yes...you're correct...the Cobra keeps running like the ignition is still in the on position...
Reply With Quote
  #13 (permalink)  
Old 08-15-2011, 08:45 PM
Rick Parker's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: May 2001
Location: California, Ca
Cobra Make, Engine: NAF 289 Slabside Early Comp Car with 289 Webers and all the goodies. Cancelling the efforts of several Priuses
Posts: 6,592
Not Ranked     
Default



MSD Ignition
__________________
Rick

As you slide down the Banister of Life, may the splinters never be pointing the wrong way
Reply With Quote
  #14 (permalink)  
Old 08-16-2011, 04:27 AM
undy's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jul 2005
Location: Virginia Beach, Va & Port Charlotte, Fl.,
Posts: 1,926
Not Ranked     
Default

Quote:
Originally Posted by Rick Parker View Post
Thanks Rick, that's what I was talking about...

BTW... mine ran for 4 years as it was wired before it started doing it.
Reply With Quote
  #15 (permalink)  
Old 08-16-2011, 06:12 AM
priobe's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Mar 2004
Location: miami, FL
Cobra Make, Engine: E-M Cobra Ford FE 427 w/ Webers 48 IDA
Posts: 1,345
Not Ranked     
Default

The diode in the alternator is bad, which is why it just started to do this.

Wire up a relay to solve this problem. If you add a diode again, it will eventually happen again.
Reply With Quote
  #16 (permalink)  
Old 08-16-2011, 10:49 AM
willow1308's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jun 2007
Location: Houston, TX
Cobra Make, Engine: Backdraft Cobra #340, Reflex Silver with Ghost Stripes/Rondells, Polished Roush 402R, TKO600
Posts: 62
Not Ranked     
Default

Quote:
Originally Posted by priobe View Post
The diode in the alternator is bad, which is why it just started to do this.

Wire up a relay to solve this problem. If you add a diode again, it will eventually happen again.

Thanks for the info...any additional details you could provide would be helpful ...what type of relay...where do I splice it in...
Reply With Quote
  #17 (permalink)  
Old 08-16-2011, 11:00 AM
priobe's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Mar 2004
Location: miami, FL
Cobra Make, Engine: E-M Cobra Ford FE 427 w/ Webers 48 IDA
Posts: 1,345
Not Ranked     
Default

Here is a link that describes the wiring for the install

How To Properly Install An Electric Fan

Any 30 amp relay will do. I prefer Bosch if you can get one
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
The representations expressed are the representations and opinions of the clubcobra.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners, moderators, Shelby American, any other replica manufacturer, Ford Motor Company. This website has been planned and developed by clubcobra.com and its forum members and should not be construed as being endorsed by Ford Motor Company, or Shelby American or any other manufacturer unless expressly noted by that entity. "Cobra" and the Cobra logo are registered trademarks for Ford Motor Co., Inc. clubcobra.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). Thank you for visiting clubcobra.com. For full policy documentation refer to the following link: CC Policy
Links monetized by VigLink