Club Cobra Keith Craft Motorsports  

Go Back   Club Cobra > Manufacturers, Engine Builders, tools, and parts. > Antique & Collectibles

Welcome to Club Cobra!  The World's largest non biased Shelby Cobra related site!

  •  » Representation from nearly all Cobra/Daytona/GT40 manufacturers
  •  » Help from all over the world for your questions
  •  » Build logs for you and all members
  •  » Blogs
  •  » Image Gallery
  •  » Many thousands of members and nearly 1 million posts! 

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Nevada Classics
MMG Superformance
Main Menu
Module Jump:
Nevada Classics
Nevada Classics
Keith Craft Racing
Advertise at CC
Banner Ad Rates
MMG Superformance
MMG Superformance
Keith Craft Racing
MMG Superformance
October 2022
S M T W T F S
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31          
  #1 (permalink)  
Old 04-15-2007, 06:52 PM
CC Member
Visit my Photo Gallery

 
Join Date: Sep 2006
Cobra Make, Engine:
Posts: 242
Not Ranked     
Default Horn Problems

Hi Everyone:Well i tried for 3 hrs to figure out why my horn wont work. When i touch the wire coming out of the horn cam from steering column to the threaded center rod where the steering Wheel gets threaded on, the horn wont go off. I dont get it. When i connect a test light to that wire and touch the cowl the horn goes off. With the light still attached to the cowl i touch the test light to the column conector (GM IDIDIT) on the column side it goes off and on the panel side it goes off so i know the the connector is together. So i go to the panel (American Autowire Highway 22 kit) and put the test light on the Horn Switch screw where the wire is attached from the column and the horn goes off. So now I attached the yellow wire from the horn cam to the horn button. The Horn button has 3 spring type wires coming out of the sides to press against the inside of the hub to hold it on and ground i am thinking. So i attached the test light to one of the springs, the other end to the cowl and pressed the button. The horn went off.
So i am thinking that the horn switch wire (Ground) isn't grounded in the panel some how. Or the Horn relay attached to the panel might be faulty.
I dont know. What do you guys think.

Thanks
Automan--
Reply With Quote
Sponsored Links
Sponsored Links
  #2 (permalink)  
Old 04-16-2007, 03:54 PM
jerry w's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jul 2003
Location: Corinth, NY
Cobra Make, Engine: Antique & Collectable 302, C-4,Ford 9 inch
Posts: 251
Not Ranked     
Default

I know this is a pain, but have you tried installing the steering wheel with the horn button in place? It sounds like you have no ground through that threaded rod, but you might have contacts on the steering wheel itself that connect through to the clip and harness. I know how it feels to stumble on a little thing like a horn, especially when you spend hours trying to figure it out. Some times another set of eyes may see something you have missed.

Good luck, keep us posted on your progress.


Regards,
__________________
Jerry
Reply With Quote
  #3 (permalink)  
Old 04-18-2007, 08:37 AM
CC Member
Visit my Photo Gallery

 
Join Date: Sep 2006
Cobra Make, Engine:
Posts: 242
Not Ranked     
Default

Hey, thanks jerry for the feedback. I called Ididit. They said almost the exact same thing that you said. That the shaft wasn't grounded. Even though i thought that with the shaft connected all the way down to the rack would be sufficient, that sometimes its not enough. He told me to drill a little hole on the column, under the dash, and screw a ground from there to my cowl which has great ground. Did it and now i have horn. Installed my steering wheel permanently now with the horn button and all is functional. Next step is the wiring of the front electric rad fans so now i have to install my rad first before i can do that.

Another battle won.
Thanks again
Automan
Reply With Quote
  #4 (permalink)  
Old 04-18-2007, 06:20 PM
jerry w's Avatar
CC Member
Visit my Photo Gallery

 
Join Date: Jul 2003
Location: Corinth, NY
Cobra Make, Engine: Antique & Collectable 302, C-4,Ford 9 inch
Posts: 251
Not Ranked     
Default

I love a happy ending! Glad things worked out. Keep us updated with pics of your build.

Regards,
__________________
Jerry
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
The representations expressed are the representations and opinions of the clubcobra.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners, moderators, Shelby American, any other replica manufacturer, Ford Motor Company. This website has been planned and developed by clubcobra.com and its forum members and should not be construed as being endorsed by Ford Motor Company, or Shelby American or any other manufacturer unless expressly noted by that entity. "Cobra" and the Cobra logo are registered trademarks for Ford Motor Co., Inc. clubcobra.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). Thank you for visiting clubcobra.com. For full policy documentation refer to the following link: CC Policy
Links monetized by VigLink